カテゴリー別アーカイブ: その他デジタル

Bootstrapを使用しているページにMS EdgeでアクセスするとLESSファイルにアクセスしようとする話

Bootstrap 3を使用しているWebサイトにMS Edgeを使ってアクセスすると、HTTP 404等の大量の400番台アクセス不可が吐かれているように見えますが、これは開発者ツールを表示している時のみの動きで、通常のアクセス時には問題ありません。

マッピングを行うためにBootstrapコンパイル元のLESSファイルを探すものの、開発環境ではない本番環境にLESSファイルがアップされているはずもなくアクセス不可、という動きのようです。

ms_edge_bootstrap

―Why is Bootstrap trying to load LESS files in Edge?
http://stackoverflow.com/questions/35142485/why-is-bootstrap-trying-to-load-less-files-in-edge

より。


Zabbix Proxyサービス起動時刻がおかしいと正常に動作しなくなる話

Zabbix Server、Zabbix Agentが導入されているサーバーを再起動することは問題ないが、Zabbix Proxyが導入されているサーバーのOSを再起動するとなぜかagent pingが飛ばなくなるという現象が有りました。以下のような状況でした。

  • OSはCentOS 7.2
  • Zabbix 3.0.2
  • zabbix-proxy.serviceは自動起動が有効。
  • キャッシュDBはSQLite3を利用。
  • systemctl restart zabbix-proxy を実行すると改善。
  • 稀にOS再起動後も問題なく動作する。

最初はProxyの設定ファイルを調査するも特に不審な点は無い状況でした。しかし、systemctl status zabbix-proxyで出てくるサービス起動時刻がおかしい事に気づきます。dateコマンドを叩いて表示される時刻はJSTとして正しいものであるものの、zabbix-proxyの起動時刻はJST + 7.x時間という中途半端な時刻になっています。9時間マイナスならともかく、JSTよりさらに先というのがよく分かりません。

  • dateコマンドで表示される時刻は正しい。
  • timedatectlで確認できるJST、UTCともに正しく、RTCはUTCと同じ値。
  • sshd等、他のサービスにもsystemctlで確認できる起動時刻がおかしいものがある。
  • psコマンドで表示される時刻は正常。
  • systemctl restart zabbix-proxyを行うとサービス起動時刻も正常なJSTになる。

時計回りの怪しさ満点ですが、結果としては「OSを起動している仮想環境のホストであるESXiの時計が狂っている」という物でした。OS上の時刻表示が正しいものだから結構気づくのに時間がかかりました。
では、なぜOS上の時刻が正しいのにサービスの起動時刻だけおかしくなるのかというと、OSの再起動時にESXiの機能が時刻同期をオフにしていてもホスト側に合わせてしまうというそんな事しなくていいのに……という処理が入るとの事。その後OS起動処理の中でchronyが動作し、ユーザーが触る頃には正しい時刻、という動きが再起動の度に挟まれていたようです。以下の記事がとても参考になりました。

―ESXi上のWindowsゲストの時刻がずれて詰みかけた話
http://qiita.com/ine1127/items/edb0a46b638265186650

なぜZabbix Proxyの起動時刻が正しくない状況にあると正常に動作しなくなるか、という点については不明ですが(まぁ正常な環境ではないのは確かですが)、とりあえず今のところは再起動後もagent pingが途切れなくなっています。


Chrome 50 + Rapport フリーズ多発の顛末

タイトルにもうオチが書いてあるようなものですが、Google Chromeのバージョンが50になった辺りから、ページ読み込み中の応答なしが多発していた現象の顛末について。

まず、Chrome 49の辺りから一部Flashの表示が崩れることが有りました。具体的には「アイドルマスター シンデレラガールズ」「アイドルマスター ミリオンライブ」等なのですが、数年前にも似たような現象の経験があり、その時と同様にFlashのハードウェアアクセラレーションを切る事で改善しました。おそらくハードウェア側の問題なのですが、GPUの動画再生支援部分だけが壊れるという現象を経験しています。ドライバの設定や再インストールでは改善せず、GPUを買い替える事で解決します。

そして、Chrome 50になってからはページ読み込み中にブラウザの応答が無くなりフリーズする事が多発するようになります。これもGPU的な問題かと思い、グラフィックスカードを取り外し、intel内臓グラフィックスに変更するなど試していますが、特に改善しませんでした。その他、以下の部分を試しても改善せずという状況。

  • GPUの変更(intel内臓への変更)
  • 全てのプラグインを無効化
  • 全キャッシュ削除
  • プロフィールファイルの再作成
  • Googleアカウントとの連携を切る
  • Chromeの再インストール
  • 念のためPC全体のウイルススキャン
  • SSDへのtrim処理
  • ディスクチェック

で、Rapportについて。これは、国内の各種インターネットバンキングサイトで導入が推奨されている、そういったサイト専用を謳う無償のセキュリティ対策ソフトです。某ネットバンキングサイトを利用するにあたり約1年以上前から導入しており、これが怪しいと思った部分も有るのですが、ChromeのRapportプラグインは「全てのプラグインを無効化」の時点で無効化しており、この時点で関係ないものだと思い込んでしまいました。

しかし、もうOSを入れなおすしかないのかなと思っていた最後になんとなく「Rapport止めてみるか」と停止させてみた所、今までのフリーズ多発が嘘のようにChromeが安定。PCを起動するたびにRapportを落とすのも面倒(自動起動の無効化は出来なかった)なので、いったんアンインストールする運びとなりました。

気づいてしまえば「セキュリティソフトが悪い」というネットトラブルあるあるな原因ですが、「あそこで関係なくなったはず」と疑う対象から外すのは、仕事での開発の上でも気を付けたい所だな、などと思ったり。

アンインストールの際に表示されるアンケートで現象は伝えているので、修正されるといいのですが。あとは、グラフィックスカードを買い替えるかどうか、しばらくはintel HD Graphicsを使うか。